Wireless N PCI Express Dual-Band Mini Half-Height Card (TPE-NHMPCIED)

Wireless N PCI Express Dual-Band Mini Half-Height Card (TPE-NHMPCIED)
The Penguin Wireless N PCI Express Dual-Band Mini Half-Height Card is perfect for use in routers and other devices needing AP mode / master mode support via hostapd.



  • Speeds up to 300Mbps

  • Dual-band 2.4 & 5 Ghz

  • Support for most popular and libre (free) distributions

  • Not dependent on NDISWrapper, binary blobs, or proprietary drivers-firmware





Fast shipping:

In the United States?
Get it in just 1-5 business days!

Category Specification
Chipset Atheros AR9382
Standard a/b/g/n
Interface Half Height MiniPCIe
Antenna Connectors Two
Security WEP, WPA. WPA2
Certifications CE, FCC
Modes of operation supported in recent kernels Station Mode, AP Mode, IBSS Mode, Monitor Mode, Mesh point, WDS, Master Mode
Supported kernels 2.6.38+
Compatible with MS Windows XP/Vista/7/8


Have questions?
E-mail support or call us at: 1-888-39-THINK (84465)


Get the right card: Check out our Mini PCI guide for help.

Notice: Many Apple, HP, Lenovo, IBM, Dell, and Toshiba branded products are defective by design. They use digital restrictions management technology and proprietary connectors to limit what hardware may be installed. This is usually a digital restriction in the BIOS that prevents the otherwise standards compliant half height Mini PCIe slot from accepting anything but wifi cards sold by the PC manufacturer. If you have a problem with this please contact support to return or exchange the product within 14 days. For impacted users we recommend a USB wifi card instead.

Partial List Of Supported Releases:

Trisquel 5, 5.5, 6, 6.01, 7, 8, 9, 10, 11
Slint 14.2, 15.0
Slackware 14, 14.1, 14.2, 15.0
Ubuntu 11.04, 11.10, 12.04, 12.10, 13.04, 13.10, 14.04, 14.10, 15.04, 15.10, 16.04, 16.10, 17.04, 17.10, 18.04, 18.10, 19.04, 19.10, 20.04, 20.10, 21.04, 21.10, 22.04, 22.10, 23.04, 23.10
Lubuntu 11.04, 11.10, 12.04, 12.10, 13.04, 13.10, 14.04, 14.10, 15.04, 15.10, 16.04, 16.10, 17.04, 17.10, 18.04, 18.10, 19.04, 19.10, 20.04, 20.10, 21.04, 21.10, 22.04, 22.10, 23.04, 23.10
Kubuntu 11.04, 11.10, 12.04, 12.10, 13.04, 13.10, 14.04, 14.10, 15.04, 15.10, 16.04, 16.10, 17.04, 17.10, 18.04, 18.10, 19.04, 19.10, 20.04, 20.10, 21.04, 21.10, 22.04, 22.10, 23.04, 23.10
Peppermint Linux OS 5, 6, 7, 8, 9, 9 Respin-2, 10, 10 Respin, 10 Respin 20191210, 2022-02-02, 2022-10-02, 2022-11-07, 2022-11-28, 2023-07-01, 2023-10-15
LXLE , 12.04.3, 12.04.4, 14.04, discontinued
elementary OS .2, .3, .3.1, .3.2, .4, .4.1, 5.0, 5.1, 5.1.2, 5.1.3, 5.1.4, 5.1.5, 5.1.6, 5.1.7, 6, 6.1, 7, 7.1
Linux Mint 11, 12, 13, 14, 14.1, 15, 16, 17, 17.1, 17.2, 17.3, 18, 18.1, 18.2, 18.3, 19, 19.1, 19.2, 19.3, 20, 20.1, 20.2, 20.3, 21, 21.1, 21.2, 21.2 Edge, 21.3, 21.3 Edge
Linux Mint Debian Edition (LMDE) 1, 2, 3, 4, 5, 6
Fedora 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39
OpenSuSE 12.1, 12.2, 12.3, 13.1, 13.2, Leap 42.1, 42.2, 42.3, 15.0, 15.1, 15.2, 15.3, 15.4, 15.5
Mageia , 2, 3, 4, 5, 5.1, 6, 6.1, 7, 7.1, 8, 9
Debian 6, 7, 8, 9, 10, 11, 12
Tails .20, .21, .22, .22.1, .23, 1.0, 1.0.1, 1.1, 1.1.1, 1.1.2, 1.2, 1.2.1, 1.2.2, 1.2.3, 1.3, 1.3.1, 1.3.2, 1.4, 1.4.1, 1.5, 1.5.1, 1.6, 1.7, 2.0, 2.0.1, 2.3, 2.4, 2.5, 2.6, 2.7, 2.7.1, 2.9.1, 2.10, 2.11, 2.12, 3.0, 3.0.1, 3.1, 3.2, 3.3, 3.5, 3.6, 3.6.1, 3.6.2, 3.7, 3.8, 3.9, 3.9.1, 3.10.1, 3.11, 3.12, 3.12.1, 3.13, 3.13.1, 3.13.2, 3.14, 3.14.1, 3.14.2, 3.15, 3.16, 4.0, 4.1, 4.1.1, 4.2, 4.2.2, 4.3, 4.4, 4.4.1, 4.5, 4.6, 4.7, 4.8, 4.9, 4.10, 4.11, 4.12, 4.13, 4.14, 4.15, 4.15.1, 4.16, 4.17, 4.18, 4.19, 4.20, 4.21, 4.22, 4.23, 4.24, 4.25, 4.26, 4.27, 4.28, 4.29, 5.0, 5.1, 5.1.1, 5.2, 5.3, 5.3.1, 5.4, 5.5, 5.6, 5.7, 5.8, 5.9, 5.10, 5.11, 5.12, 5.13, 5.14, 5.15.1, 5.16, 5.16.1, 5.17, 5.18, 5.19, 5.19.1, 5.20, 5.21, 5.22
PCLinuxOS 2011.6, 2011.9, 2012.2, 2013.2, 2013.4, 2013.6, 2013.7, 2013.715, 2013.10, 2013.12, 2014.04, 2014.05, 2014.07, 2014.08, 2014.12, 2016.03, 2016.07, 2017.04, 2017.05, 2017.07, 2017.11, 2018.06, 2019.03, 2019.05, 2019.08, 2019.10, 2019.11, 2019.12, 2020.01, 2020.02, 2020.03, 2020.05, 2020.08, 2020.10, 2020.1015, 2021.0205, 2021.0215, 2021.08, 2021.11, 2022.01.10, 2022.04.10, 2022.04.20, 2022.07.10, 2022.11.20, 2022.11.30, 2022.12, 2023.05, 2023.07, 2023.08
Red Hat Enterprise Linux (RHEL) 9 Series 9.0, 9.1, 9.2, 9.3
Red Hat Enterprise Linux (RHEL) 8 Series 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8, 8.9
Red Hat Enterprise Linux (RHEL) 7 Series 7.0, 7.1, 7.2, 7.3, 7.4, 7.5, 7.6, 7.7, 7.8, 7.9, 7 ELS+
Red Hat Enterprise Linux (RHEL) 6 Series 6.5, 6.6, 6.7, 6.8, 6.9, 6.10, 6 ELS+
Rocky Linux 9 Series 9.0, 9.1, 9.2, 9.3
Rocky Linux 8 Series 8.4, 8.5, 8.6, 8.7, 8.8, 8.9
AlmaLinux 9 Series 9.0, 9.1, 9.2, 9.3
AlmaLinux 8 Series 8.3, 8.4, 8.5, 8.6, 8.7, 8.8, 8.9
CentOS Stream 8, 9
CentOS 8 Series 8.0, 8.1, 8.2, 8.3, (discontinued)
CentOS 7 Series 7.0, 7.1, 7.2, 7.3, 7.4, 7.5, 7.6, 7.7, 7.8, 7.9
CentOS 6 Series 6.5, 6.6, 6.7, 6.8, 6.9, 6.10
Scientific Linux 7 Series 7.0, 7.1, 7.2, 7.3, 7.4, 7.5, 7.6, 7.7, 7.8, (discontinued)
Scientific Linux 6 Series 6.5, 6.6, 6.7, 6.8, 6.9, 6.10, (discontinued)
Manjaro 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 15.09, 15.12, 16.06, 16.06.1, 16.08, 16.10, 17.0, 17.1, 18.0, 18.1.0, 19.0, 20.0, 20.1, 20.2, 20.2.1, 21.0, 21.0.1, 21.0.2, 21.0.3, 21.0.4, 21.0.5, 21.0.6, 21.0.7, 21.1.0, 21.1.1, 21.1.2, 21.1.3, 21.1.4, 21.1.5, 21.1.6, 21.2.0, 21.2.1, 21.2.2, 21.2.3, 21.2.4, 21.2.5, 21.2.6, 21.3.1, 21.3.2, 21.3.3, 21.3.4, 21.3.5, 21.3.6, 21.3.7, 22.0, 22.0.1, 22.0.2, 22.0.3, 22.0.4, 22.0.5, 22.1.0, 22.1.1, 22.1.2, 22.1.3, 23.0, 23.0.1, 23.0.2, 23.0.3, 23.0.4, 23.1.0, 23.1.1, 23.1.2, 23.1.3
Arch 2011.08.19, 2012.07.15, 2012.08.04, 2012.09.07, 2012.10.06, 2012.11.01, 2012.12.01, 2013.01.04, 2013.02.01, 2013.03.01, 2013.04.01, 2013.05.01, 2013.06.01, 2013.07.01, 2013.08.01, 2013.09.01, 2013.10.01, 2013.11.01, 2013.12.01, 2014.01.05, 2014.02.01, 2014.03.01, 2014.04.01, 2014.05.01, 2014.06.01, 2014.07.03, 2014.08.01, 2014.09.03, 2014.10.01, 2014.11.01, 2014.12.01, 2015.01.01, 2015.02.01, 2015.03.01, 2015.04.01, 2015.05.01, 2015.06.01, 2015.07.01, 2015.08.01, 2015.09.01, 2015.10.01, 2015.11.01, 2015.12.01, 2016.01.01, 2016.02.01, 2016.03.01, 2016.04.01, 2016.05.01, 2016.06.01, 2016.07.01, 2016.08.01, 2016.09.03, 2016.10.01, 2016.11.01, 2016.12.01, 2017.01.01, 2017.02.01, 2017.03.01, 2017.04.01, 2017.05.01, 2017.06.01, 2017.07.01, 2017.08.01, 2017.09.01, 2017.10.01, 2017.11.01, 2017.12.01, 2018.01.01, 2018.02.01, 2018.03.01, 2018.04.01, 2018.05.01, 2018.06.01, 2018.07.01, 2018.08.01, 2018.09.01, 2018.10.01, 2018.11.01, 2018.12.01, 2019.01.01, 2019.02.01, 2019.03.01, 2019.04.1, 2019.05.1, 2019.06.1, 2019.07.1, 2019.08.1, 2019.09.1, 2019.10.1, 2019.11.1, 2019.12.1, 2020.01.1, 2020.02.1, 2020.03.1, 2020.04.1, 2020.05.1, 2020.06.1, 2020.07.1, 2020.08.1, 2020.09.1, 2020.10.1, 2020.11.1, 2020.12.1, 2021.01.1, 2021.02.1, 2021.03.1, 2021.04.1, 2021.05.1, 2021.06.1, 2021.07.1, 2021.08.1, 2021.09.1, 2021.10.1, 2021.11.1, 2021.12.1, 2022.01.1, 2022.02.1, 2022.03.1, 2022.04.1, 2022.05.1, 2022.06.1, 2022.07.1, 2022.08.1, 2022.09.1, 2022.10.1, 2022.11.1, 2022.12.1, 2023.01.1, 2023.02.1, 2023.03.1, 2023.04.1, 2023.05.1, 2023.06.1, 2023.07.1, 2023.08.1, 2023.09.1, 2023.10.1, 2023.11.1, 2023.12.1, 2024.01.1, 2024.02.1
Batocera 29, 30, 31, 32, 33, 34, 35, 36, 37, 38


All recently released distributions are compatible.

Are you assembling a new computer? Need to replace a damaged antenna? Well, we have good news. We also stock a number of different types of antenna compatible with this card.

Get inexpensive hassle-free repair, replacement, and support for your device. Whether it's been damaged or you just can't figure out why it's not working we'll be here to help. Purchase up to 3 years of total support and protection.

As full and half height slots are compatible with each other aside from the physical size differences you can pick up a mini PCIE half height to full height card bracket such that the half height card will now fit your full height slot.